1.7.14: Compiling GCC fails (Permission denied on mv)

Ryan Johnson ryan.johnson@cs.utoronto.ca
Wed Jul 11 19:59:00 GMT 2012


On 11/07/2012 8:39 AM, Thorolf Schulte wrote:
> Hi,
>
> this is my first mail on the mailing list, so please excuse any mistakes.
>
> I am trying to compile GCC 4.6.1 on my Cygwin 1.7.14 following this:
> http://cygwin.wikia.com/wiki/How_to_install_a_newer_version_of_GCC
>
> I downloaded and installed every package needed (GMP, MPFR, 
> Multiprecision).
> Then I went into my build folder and typed
> ../gcc-4.6.1/configure --enable-languages=c,c++ --enable-libgomp 
> --with-multilib-list=m64,m32 --prefix $HOME/gcc64pls --program-suffix 
> -64pls
>
> (I need OMP and 64 bit support as my programs need more than 2 gb RAM!)
> That worked fine, but just for completeness, I attached the output as 
> "confout.txt".
>
> Now I try to build GCC with "make -j4". Here the problem occurs: The 
> data cannot be moved from "gcc" to "stage1-gcc" (Permission denied). 
> After this error I checked the build folder and saw that the 
> corresponding folder is not there. Then I tried to manually add all 
> folders necessary, but it seems that they get deleted during build 
> progress (saw some rm -r in Makefile). So I get exactly the same 
> problem after manually adding all folders.
> I wanted to attach the full output as well, but the file size with 
> >800kb seemed to be too big. I just attached the last 10-20%, but of 
> course I can send the other output as well.
>
> Additionally, I attached my version information in "cygcheck.txt".
>
> Currently, I just dont know what to do. I tried to find some help via 
> Google or the archive, but it seems that I am the only one facing this 
> exact problem.
>
> Any (general) advice? Thanks!
Ignore the wikia article. Third party "advice" on how to use cygwin is 
usually outdated and/or flat out wrong. The multilib thing is especially 
suspicious, given that cygwin is *not* 64-bit capable.

I'd follow the directions at gcc's site, or -- even better -- invoke 
`/usr/bin/gcc -v' and copy its known-good configure line. I've compiled 
many versions of gcc with many versions of cygwin that way without 
difficulty.

$ uname -a
CYGWIN_NT-6.1-WOW64 ryan-cms-utsc 1.7.14(0.260/5/3) 2012-04-25 09:41 
i686 Cygwin

$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/home/Ryan/apps/gcc-4.7/libexec/gcc/i686-pc-cygwin/4.7.0/lto-wrapper.exe
Target: i686-pc-cygwin
Configured with: ../gcc-4.7.0-src/configure 
--prefix=/home/Ryan/apps/gcc-4.7 --enable-bootstrap 
--enable-version-specific-runtime-libs --enable-static --enable-shared 
--enable-shared-libgcc --disable-__cxa_atexit --with-dwarf2 
--disable-sjlj-exceptions --enable-languages=c,c++,lto --enable-lto
Thread model: single
gcc version 4.7.0 (GCC)

Ryan


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list