Hang when launching WiX's candle.exe with cygwin 1.7.15. Runs OK with 1.7.9

Graham Perks graham@kace.com
Fri Jul 6 21:10:00 GMT 2012


- Install Windows 7 x64, with VS2008 + SP1.
- Install WiX 3.5 (Windows Installer builder), from
http://wix.codeplex.com/releases/view/60102; Wix35.msi.
- Install cygwin base.
- Add C:\Program Files (x86)\Windows Installer XML v3.5\bin to your PATH
(via Control Panel)
- Open Cygwin Terminal
- Type 'candle' - terminal hangs. Apparently no new processes are kicked
off, per Task Manager.

With an older cygwin (I had 1.7.9(0.237/5/3) 2011-03-29 available), and
candle.exe runs correctly, showing the available command options.

I've tried working around this by executing 'cmd /c candle.exe ...' but
wind up with the same result, a hang.

Any ideas on workarounds or fixes?

Graham Perks.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.txt
URL: <http://cygwin.com/pipermail/cygwin/attachments/20120706/4eeff7ff/attachment.txt>
-------------- next part --------------
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list