"dst_lib_init: openssl failure" solved: openssl depedancy is missing in the "bind" component.

Niels Kristian Jensen nkj@internetgruppen.dk
Wed Aug 22 18:10:00 GMT 2012

This problem is still around, I just ran into it.


How to reproduce:

I use setup.exe version 2.774 on Win XP.

I installed "bind" version 9.9.1-P2-1 from the "Net" section. openssl 
was not installed before and was not found in the dependancy list.

Running dig (part of the Bind package), I got the error:

"dst_lib_init: openssl failure"

This was solved by installing "openssl" as hinted here:


In other words, openssl should be added to the dependancy list of the 
"bind" package, otherwise "dig" will not run.

Best regards,
Niels Kristian Jensen

P.S: Sorry if this has been reported before, but I could not find any 
backlog of already reported problems (I did try google.com and the 
mailing list archive on sourceware.org)

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list