Please test snapshots

Christopher Faylor
Thu Aug 16 19:01:00 GMT 2012

On Tue, Aug 14, 2012 at 12:48:03PM +0000, Adam Dinwoodie wrote:
>Christopher Faylor wrote:
>>On Fri, Aug 10, 2012 at 06:31:25AM +0000, Achim Gratz wrote:
>>>Daniel Colascione writes:
>>>>It works for me in bash.  I don't have tcsh installed, but I don't see why
>>>>SIGINT would work differently there.
>>>Yes, it works in bash for me, too.  Tcsh does something that apparently
>>>breaks with the new snapshot, but since I don't get any error messages, it's
>>>hard to tell what that might be.
>>You're not really giving us much to go on.  I've tried ping (both Windows and
>>Cygwin version) under tcsh and both work fine.  And, the small snippet that
>>you cut/paste in your original bug report clearly showed that ping was
>>responding to CTRL-C.
>I'm still using this snapshot (I've had no reason to stop until now),
>and have hit this issue two out of the last five times running Cygwin
>ping.  The ping process is still visible in Process Explorer after
>hitting ^C.  There's no obvious difference between when ^C terminates
>the process and when it doesn't.

I managed to duplicate this once a couple of days ago in a mintty/tcsh
process but I had a very hard time consistently hitting it.  So I wrote
a test case which ran ping repeatedly in a loop under mintty while another
process killed it.  Eventually, I could duplicate the problem in a few
minutes.  There were two problems, one illustrated by the "sigwaitinfo"
mentioned in another thread and another caused by a race.

After making some changes to signal handling, I ran the test case for an
afternoon without issue.

The current snapshot has these changes.

I'd appreciate feedback on whether or not this fixes this problem.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list