Cygwin setup scrambled permissions

Lord Laraby
Mon Aug 13 11:10:00 GMT 2012

I just downloaded the latest setup.exe from www DOT cygwin DOT com and
run it as normal selected only updated packages.

However, several errors began to popup in warning windows about files
being in use. However, there was not a single active cygwin process or
service running. That got me suspicious as retry just kept repeating
itself. So, dropping to CMD and running:

dir /Q file  (on several of the bad directies)

showed that they were not accessible - no read, no write, no execute,
no read dac, no take ownership, etc. Not even as a SYSTEM account. (I
have psExec -s) to elevate to SYSTEM status for emergencies like this
one. No a single account has take ownership abilities or even read
owner abilities.

> getfacl -d etc/skel     (for instance)

# file: etc/skel
# owner: ????????
# group: ????????

My /etc/profile and /etc/passwd were just fine before the update.
Everything should have worked. The only files / dirs that were messed
up had today's date.

> uname -a
CYGWIN_NT-6.1-WOW64 Master-PC 1.7.16(0.262/5/3) 2012-07-20 22:55 i686 Cygwin

> id
uid=1001(Master) gid=513(None)

I am running under an Administrator Group account.

Also, when I ran setup.exe I chose "run as Administrator".

Let me know if you need more information to help out with the diagnosis.

Terry Lincoln

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list