Please test snapshots

Christopher Faylor
Fri Aug 10 14:36:00 GMT 2012

On Fri, Aug 10, 2012 at 06:31:25AM +0000, Achim Gratz wrote:
>Daniel Colascione writes:
>>It works for me in bash.  I don't have tcsh installed, but I don't see
>>why SIGINT would work differently there.
>Yes, it works in bash for me, too.  Tcsh does something that apparently
>breaks with the new snapshot, but since I don't get any error messages,
>it's hard to tell what that might be.

You're not really giving us much to go on.  I've tried ping (both
Windows and Cygwin version) under tcsh and both work fine.  And, the
small snippet that you cut/paste in your original bug report clearly
showed that ping was responding to CTRL-C.

>I tried it again in tcsh, and the SIGINT clearly did not get delivered
>to ping (the process was still running) and I had to kill it from
>another shell.  Once I did that, the prompt in tcsh came back.  I can
>kill other processes in tcsh, but sometimes they are not properly
>terminated, like here:
>...  pty0    85441 08:14:58 /usr/bin/git <defunct>

A <defunct> process doesn't mean that something is not properly
terminated.  Is this also a tcsh shell running git?

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list