Random segmentation faults since upgrade to Cygwin 1.7.16

Buist, Eric Eric.Buist@nuance.com
Fri Aug 10 03:35:00 GMT 2012


I am running Cygwin 1.7 under Windows 7 64 bits for some time without problems, except it is sometimes slow when performing tab completion.

But after I upgraded to Cygwin 1.7.16, no more Cygwin tool is working correctly. Even simple commands such as ls, uname, dirname, or bash -version return nothing or crash with segmentation fault. I tried using the setup to downgrade to Cygwin 1.7.15 without success. I tried reinstalling Cygwin completely and got the 1.7.16 again, without any change. I then tried downgrading to Cygwin 1.7.9 from an old tar.bz2 file I had. I got a bit more success, but dirname was returning nothing at all. I tried running as an Administrator, tried Windows XP compatibility mode: no change. I tried a 1.7.17 snapshot Cygwin DLL: no change. Any search on Google or mailing list archives give completely off-topic segmentation faults about programs compiled with GCC, but I am not compiling anything, just running precompiled tools. Even if I reinstall Cygwin, I will get the new 1.7.16 DLL and that will crash again. It seems I will really have to try this in a Windows XP virtual machine, but that is a lot of work for something that was working correctly before. I don't have any old downloaded Cygwin files I could use to reinstall a complete old stack so I am quite stuck.

Thanks in advance.

Eric Buist, Ph.D
Research Engineer | Natural Language Understanding
Nuance Communications, Inc.
1500 University - Suite 935
Montreal, QC
H3A 3S7
Tel: (514) 904-7800 - "Just say my name"
Fax: (514) 940-6826

This email and its attachments are Confidential Information of Nuance Communications, Inc.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list