crash on latest cygwin snapshot

Ken Brown
Thu Aug 2 15:57:00 GMT 2012

On 8/1/2012 8:58 AM, Corinna Vinschen wrote:
> On Aug  1 08:46, Ken Brown wrote:
>> On 8/1/2012 8:29 AM, Corinna Vinschen wrote:
>>> On Aug  1 12:34, marco atzeri wrote:
>>>> On 8/1/2012 11:43 AM, Corinna Vinschen wrote:
>>>>> Hi Marco, Hi Ken,
>>>>> On Jul  2 16:43, marco atzeri wrote:
>>>>>> On 6/27/2012 3:46 AM, Christopher Faylor wrote:
>>>>>>> Sorry, Marco.  Nevermind.  I duplicated this.  No need to upload anything.
>>>>>>> I'm still working on it.
>>>>>>> cgf
>>>>>> it seems solved on 20120702 snapshots
>>>>> can you please test your crashing scenarios with the latest developer
>>>>> snapshot from today?  After some private discussion, cgf and I have a
>>>>> hunch that the underlying problem was the problem I fixed yesterday, and
>>>>> cgf's changes to on 2012-07-01 made just enough changes in
>>>>> code optimization so that your problem wasn't visible anymore.
>>>>> I reverted cgf's changes to and generated the today's
>>>>> snapshot specificially to test our hypothesis.  Please give it a try.
>>>>> Thanks,
>>>>> Corinna
>>>> $ uname -a
>>>> CYGWIN_NT-6.1-WOW64 MARCOATZERI 1.7.17s(0.262/5/3) 20120801 11:02:01
>>>> i686 Cygwin
>>>> is not crashing.
>>> Thanks for the quick feedback!  Now let's see what Ken reports...
>> I never had a reliable way of reproducing the crash (see
>>  It happened
>> seemingly at random, and very sporadically.  But I have the snapshot
>> installed and will exercise it as much as I can.
> Thanks!

The good news: I haven't seen a repeat of that old crash so far. 
Unfortunately, I'm finding that emacs is unstable:  The emacs window 
(running under X) simply disappears after 12-24 hours.  This may not 
have anything to do with the most recent changes.  I haven't yet tested 
any earlier snapshots.

Testing this is a very slow process, since I don't know how to produce 
the problem; I just have to wait and see if emacs will die.

I tried to get some information by running emacs under gdb the most 
recent time I started it, but all I got was this:

(gdb) c
[Inferior 1 (process 8196) exited with code 05400]
(gdb) bt
No stack

Does that exit code mean anything to you?  I couldn't find anything by 


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list