bash 2112 exception::handle: Exception: STATUS_ACCESS_VIOLATION

Kris Thielemans
Fri Sep 30 15:56:00 GMT 2011


I'm running (up-to-date) Cygwin 1.7.9-1 on Windows7 sp1 64-bit.

I recently am getting lots of errors like this

bash 2112 exception::handle: Exception: STATUS_ACCESS_VIOLATION

The messages do not happen all the time (for example, from bash (in minty) I
do a few times ls. After about 4, I get 1-2 of these messages). They seem to
mention only bash or sh. Here's an example of the stackdump

Exception: STATUS_ACCESS_VIOLATION at eip=6102048B
eax=00F70598 ebx=612454AC ecx=74C00F81 edx=003451F8 esi=00000000
ebp=61020C00 esp=0028C7C4 program=C:\cygwin\bin\bash.exe, pid 6236, thread
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame     Function  Args
End of stack trace

This seems to happen with pretty much all Cygwin programs (I've tried rsync,
ls, cat, vi, gcc). The strange thing is of course that the exception
mentioned is always in bash or sh, but that the actual program is just
running fine. (Just as a sanity check I set PS1=\$, but still the same).

Up to recently, everything was fine on my system. It might have started
after I did a rebaseall but I am unfortunately not sure.

What can I do to debug this?



-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.log
Type: application/octet-stream
Size: 11433 bytes
Desc: not available
URL: <>
-------------- next part --------------
Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list