EXTERNAL: Re: Cygwin too slow while installing and working

João Moreira braelok@gmail.com
Tue Sep 20 18:07:00 GMT 2011


On Wed, Sep 14, 2011 at 7:40 PM, Larry Hall (Cygwin) wrote:
>
> On 9/14/2011 2:22 PM, João Moreira wrote:
>>
>> I checked the BLODA list again and I only had Avira installed.
>> Could it have something to do with a windows update? I keep my OS updated.
>
> No, but you're on the right track in thinking beyond the BLODA list.  That's
> a list apps known to cause problems.  But it can't be seen as a complete
> list.  So it's worth reviewing other things you have installed.
>
>> I got Procmon and messed around with it a little but i honestly don't
>> know how I can use it to pin down the problem.
>> Could you help me guys?
>
> You're looking for processes that are running while you're in the middle
> of a slow operation, particularly if they are getting more CPU than your
> Cygwin process or are trying to access the same files.
>

I ran Procmon. During startup of cygwin, which took about 40 seconds,
the only processes running besides bash.exe were:

cmd.exe
csrss.exe
conhost.exe

SearchProtocolHost.exe
SearchIndexer.exe
EXPLORER.EXE

svchost.exe
id.exe
hostname.exe
grep.exe
echo.exe

The first 3 only showed briefly at the start.
The search and explorer exes appeared during short intervals which I
guess is normal.
Of the last 5, id.exe appeared the most and hostname.exe the least.

I noticed that bash.exe accessed a lot of windows system files.

Don't know If i am applying the correct filters though...(I used the
default filter)

João

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list