plotting from octave: address space already occupied, fork aborts

Marco atzeri
Thu Sep 15 04:35:00 GMT 2011

On 9/15/2011 4:28 AM, Paul wrote:
> Marco atzeri<marco.atzeri<at>>  writes:
>> On 9/14/2011 5:33 PM, Paul wrote:
>>> Marco atzeri<marco.atzeri<at>>   writes:
>>>> The right command should be:
>>>> $ rebaseall -s 'dll|so|oct'
>>> Thanks again, Marco.  Unfortunately, still no joy after redoing you
>>> rebaseall&   peflagsall statements and rebooting.
>        <...snip...>
>> I suspect your Windows 7 Enterprise 64-bit is using more space
>> than rebaseall and cygwin expects.
>> After the plot error could you check the octave PID with
>> ps and attach a copy of
>> /proc/OCTAVE_PID/maps
>> file ?
>> It should give us an idea of unavailable address space on your system
>> due to the MS system and other programs dll's.
> I made a mistake, it's actually Windows 7 Enterprise 32-bit.
> The workplace has an atmosphere of vigilence toward sharing info about
> work related assets in the open.  I will try to duplicate the problem
> at home and post the specified details.
>     <...some time later...>
> Unfortunately, duplicating it at home is a no-go.  I am running into a
> different problem between octave and gnuplot on Windows 7 Professional
> 64-bit.  The problem seems to be accurately captured by someone else's
> account .

that problem should be solved using a cygwin snapshot dll
instead of 1.7.9-1 one.

I should look in all the bug reports reporting cygwin as "OS", thank
for the link.

> I'm going to treat octave as a strictly nongraphical application for
> the time being.

you can try to use the fltk plotting interface instead of gnuplot
default one:


Be aware that the octave "print" command does not work with fltk,
but you should be able to make a windows "print screen copy".

> Thanks again.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list