plotting from octave: address space already occupied, fork aborts

Marco atzeri
Wed Sep 14 21:27:00 GMT 2011

On 9/14/2011 5:33 PM, Paul wrote:
> Marco atzeri<marco.atzeri<at>>  writes:

>> The right command should be:
>> $ rebaseall -s 'dll|so|oct'
> Thanks again, Marco.  Unfortunately, still no joy after redoing you
> rebaseall&  peflagsall statements and rebooting.  I got the same error
> as before:
> octave:1>  plot(1:5,1:5)
>        9 [main] octave-3.4.2 5952 child_info_fork::abort: address space needed by
>        'cellfun.oct' (00570000) is already occupied
> error: popen2: process creation failed -- Resource temporarily unavailable
> error: called from:
> error: /usr/share/octave/3.4.2/m/plot/__gnuplot_open_stream__.m at line 30,
>         column 44
> error: /usr/share/octave/3.4.2/m/plot/__gnuplot_drawnow__.m at
>         line 72, column 19
> --

I suspect your Windows 7 Enterprise 64-bit is using more space
than rebaseall and cygwin expects.

After the plot error could you check the octave PID with
ps and attach a copy of

file ?

It should give us an idea of unavailable address space on your system
due to the MS system and other programs dll's.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list