Cygwin too slow while installing and working

João Moreira braelok@gmail.com
Tue Sep 13 09:15:00 GMT 2011


Hello everyone,
yesterday I started noticing some slowness in mintty.
I was just compiling some C++ code to run outside cygwin (with
-mno-cygwin) in windows. It didn't work at the time because I forgot
to link some libraries.
But anyway, I gave up then but when I latter restarted mintty it took
a long time to start and my user name no longer appeared in the shell.
Instead I got "-bash-4.1$".
Not only that, but doing an "ls" also took more than usual. I tried it
in the cygwin window itself but, while my username was now showing, it
was still very slow.

I then decided to do a clean install. Removed everything (registry
keys included), downloaded the latest installer (2.738) and tried
again (running as admin).
However, during the "postinstall scripts" part of the setup, it was
really, really slow. It took about 40 mins to finish this part (about
20 scripts).
I removed my antivirus (Avira Antivir), installed and ran rebaseall
but to no avail. A reinstall still took forever, and searching was
still too slow.
Tried installing to a directory with no whitespaces (C:\) but got the
same results.

I am using Windows Ultimate 64 running on Intel64 bit. I include a
redacted cygcheck.out in attachment.

Can you help me guys?


Thanks in advance

Joao Moreira
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 21860 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20110913/fd37d4ae/attachment.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list