Error with ./compile and make

Mitchel Craun mitchel_john_craun@yahoo.com
Sat Oct 29 01:53:00 GMT 2011


Hello  World,

I am trying to install a package on my computer (Windows 7 64) that was written 
primarily for a Linux instillation.  I am using cygwin to accomplish this.  The 
Install notes for the package I am trying to use say I can either run 
./configure
make
make install

or I can use cmake then   
make
make install

If I just run ./configure  I get the error

line 21: $'\r': command not found 
line 32: syntax error near unexpected token `$'in\r'' 
line 32: `   case   1(set -o) 2>/dev/null` in 

To resolve this I use Vim and run
:set fileformat=unix
I then enter  ./configure  into the terminal and get the following error.

configure: error: cannot run /bin/sh config/config.sub

I have not figured out how to fix this yet.
I then tried using cmake and am able to run that.  However, once it is finished 
I type    make    into the terminal and I get the following error

src/nvec_ser/CMakeFiles/sundials_nvecserial_shared_dir/build.make:53: *** target 
pattern contains no `%'. stop. 
make[1]: *** [src/nvec_ser/CMakeFiles/sundials_nvecserial_shared.dir/all] Error 
2 
make: *** [all] Error 2 


Does anyone have any idea on how I can fix either or both of these issues?  For 
the  configure: error: cannot run /bin/sh config/config.sub  error I tried 
changing /bin/sh to  C:/cygwin/bin/sh in the configure file, but that did not 
help.

Please help me!  :,(


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list