Request update of TCL and expect packages

Dave iamdave@glidefree.com
Thu Oct 27 18:30:00 GMT 2011


On 10/26/2011 3:27 PM, Marco Atzeri wrote:
>
> After chatting with Craig I dug the archives and
> I presume the main issue is how to upgrade tcl/tk
> and all the packages that depend froms it
> assuming that everything works and nothing is broken.
> The problem was already mentioned long time ago
>
I hope this isn't a dumb question...

Since TCL is designed to support multiple versions installed 
simultaneously, and there are already quite a few Cygwin packages that 
have dependencies on various versions of libraries, why not have a new 
TCL85 and EXPECT545 packages? Just leave all the other packages that 
depend on TCL8.4 alone? Perhaps Mr. Miller would volunteer to be the 
Cygwin package owner for these two new packages. Even if he were to 
abandon support, the situation would be better since we'd have >much< 
more modern versions of TCL/EXPECT for Cygwin.




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list