cygwin permissions problem on a network drive

Lemke, Michael SZ/HZA-ZSW
Fri Oct 21 14:14:00 GMT 2011

On October 21, 2011 12:55 PM Corinna Vinschen wrote:
>On Oct 21 12:15, Lemke, Michael  SZ/HZA-ZSW wrote:
>> On Friday, October 21, 2011 10:50 AM
>> Corinna Vinschen wrote:
>> >
>> >On Oct 20 18:58, gds wrote:
>> >> On 10/18/2011 08:52 AM, Lemke, Michael SZ/HZA-ZSW wrote:
>> >> 
>> >> >
>> >> >I know this an old thread but I am in exactly the same situation as
>> >> >the OP.  Access with 1.7.7 and before worked fine, 1.7.9 has this
>> >> >problem.  The workaround with explicit noacl option works for me but
>> >> >it is rather awkward as I have to work with a lot of servers.
>> >> >
>> So from the reply below I take it hasn't been fixed/worked
>> around in a snapshot.  But my experiments show something has
>Wrong.  It has been fixed in the snapshot.  1.7.9 tries to open the file
>with WRITE_DAC access which fails on some shares.  The snapshots won't
>do that anymore.

Excellent.  That explains my observations.

>> >I explained what the problem is already.  The buzzword is WRITE_DAC.
>> >Apparently you don't have permissions to change file permissions 
>> >on that share.  Cacls should show the exact layout of the file and
>> >directory DACLs.  Does `chmod' work for you?  It shouldn't either.
>> In my case that it true, chmod fails.
>Good!  That shows that my assumption is correct.
>> This is by design here.  IT wants it that way.
>Then "noacl' is the only way for you.

Unless I wait for the next release, right?

>> >
>> >Again, I don't know why this happens.  I can not reproduce this problem
>> >on my NTFS shares, other than by removing the WRITE_DAC permission from
>> >the affected files and directories.  If there's any way to fix or
>> >workaround it in Cygwin, somebody who has that problem has to hunt it
>> >down.
>> >
>> I am willing to try to hunt it down.  What do you want me to check?
>Check with your admin and ask how they make sure that you can't set
>permissions.  Did they just create a certain set of inheritable
>permissions or do they use some policy?  That is what I'd like to know.

I don't have a definitive answer yet but it looks like it's a
policy.  In Windows Explorer I have Full Access for the top level
dir.  That is inherited by every subdir and files.  But the security
entry is greyed out, also for subdirs.


More information about the Cygwin mailing list