cygwin permissions problem on a network drive

Lemke, Michael SZ/HZA-ZSW lemkemch@schaeffler.com
Fri Oct 21 10:16:00 GMT 2011


On Friday, October 21, 2011 10:50 AM
Corinna Vinschen wrote:
>
>On Oct 20 18:58, gds wrote:
>> On 10/18/2011 08:52 AM, Lemke, Michael SZ/HZA-ZSW wrote:
>> 
>> >
>> >I know this an old thread but I am in exactly the same situation as
>> >the OP.  Access with 1.7.7 and before worked fine, 1.7.9 has this
>> >problem.  The workaround with explicit noacl option works for me but
>> >it is rather awkward as I have to work with a lot of servers.
>> >
>> >So...
>> >
>> 
>> >
>> >...has this happened now?  In a snapshot?  I couldn't find any
>> >further information.

So from the reply below I take it hasn't been fixed/worked
around in a snapshot.  But my experiments show something has
changed.  With the snapshot I can create a file, with the standard
1.7.9 dll I can't.
 
>> 
>> Same problem here. Someone said snapshots here,
>> http://cygwin.com/snapshots/ , fixes the problem but I tried several
>> cygwin1.dll from there and still have problems.
>> Directory is created on network drive now but see message "can't set
>> permissions ... on a file" when committing with svn.
>
>I explained what the problem is already.  The buzzword is WRITE_DAC.
>Apparently you don't have permissions to change file permissions 
>on that share.  Cacls should show the exact layout of the file and
>directory DACLs.  Does `chmod' work for you?  It shouldn't either.

In my case that it true, chmod fails.

>
>You could talk to your admin first to find out if that is by design and
>maybe there could be something changed to allow changing permissions.

This is by design here.  IT wants it that way.

>Otherwise, just mount the share with the noacl flag.
>
>Again, I don't know why this happens.  I can not reproduce this problem
>on my NTFS shares, other than by removing the WRITE_DAC permission from
>the affected files and directories.  If there's any way to fix or
>workaround it in Cygwin, somebody who has that problem has to hunt it
>down.
>

I am willing to try to hunt it down.  What do you want me to check?
Hm, it seems something really has changed, I can't reproduce the
problem at the moment.  I can create a file, delete it but can’t
change permissions.  The latter breaks d2u:

$> touch /u/blubb
$> d2u /u/blubb
dos2unix: Failed to change the permissions of temporary output file /u/d2utmpaF6gvB: Permission denied
dos2unix: converting file /u/blubb to Unix format ...
dos2unix: problems converting file /u/blubb
$> rm /u/blubb
rm: remove regular empty file `/u/blubb'? y
$>

Is there anything in the snapshot that could explain it?  Or
did I mess up everything here?  Confused...

Well, I just cross checked.  Reinstalled 1.7.9 and the problem
is back.  So the snapshot seems to have fixed it.  That is,
this snapshot:
CYGWIN_NT-5.1 p01080268 1.7.10s(0.253/5/3) 20111017 18:26:05 i686 Cygwin
Didn't try the latest.  With the snapshot it behaves like 1.7.7 apparently.

Michael


More information about the Cygwin mailing list