cygwin permissions problem on a network drive

Corinna Vinschen
Fri Oct 21 08:50:00 GMT 2011

On Oct 20 18:58, gds wrote:
> On 10/18/2011 08:52 AM, Lemke, Michael SZ/HZA-ZSW wrote:
> >
> >I know this an old thread but I am in exactly the same situation as
> >the OP.  Access with 1.7.7 and before worked fine, 1.7.9 has this
> >problem.  The workaround with explicit noacl option works for me but
> >it is rather awkward as I have to work with a lot of servers.
> >
> >So...
> >
> >
> >...has this happened now?  In a snapshot?  I couldn't find any
> >further information.
> >
> >
> >Thanks,
> >Michael
> Same problem here. Someone said snapshots here,
> , fixes the problem but I tried several
> cygwin1.dll from there and still have problems.
> Directory is created on network drive now but see message "can't set
> permissions ... on a file" when committing with svn.

I explained what the problem is already.  The buzzword is WRITE_DAC.
Apparently you don't have permissions to change file permissions 
on that share.  Cacls should show the exact layout of the file and
directory DACLs.  Does `chmod' work for you?  It shouldn't either.

> Strangely, if I commit from linux to the same mounted ntfs drive, it works.

Linux doesn't care for the DACL.

> Haven't tried the noacl method.

You could talk to your admin first to find out if that is by design and
maybe there could be something changed to allow changing permissions.
Otherwise, just mount the share with the noacl flag.

Again, I don't know why this happens.  I can not reproduce this problem
on my NTFS shares, other than by removing the WRITE_DAC permission from
the affected files and directories.  If there's any way to fix or
workaround it in Cygwin, somebody who has that problem has to hunt it


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list