Problems with mkpasswd and mkgroup

Edvardsen Kåre
Thu Oct 13 19:27:00 GMT 2011

Greetings, Kеre Edvardsen!

> I've installed cygwin "system wide" on a client (W7 32b) from an account
> with full Administrators privileges. However, opening a Bash shell (or
> xterm) as another user prompts:

>      Your group is currently "mkpasswd".  This indicates that your
>      gid is not in /etc/group and your uid is not in /etc/passwd

>      The /etc/passwd (and possibly /etc/group) files should be rebuilt.
>      See the man pages for mkpasswd and mkgroup then, for example, run

>      mkpasswd -l [-d] > /etc/passwd
>      mkgroup  -l [-d] > /etc/group

>      Note that the -d switch is necessary for domain users.

> Before asking too many questions I should inform you that the settings
> etc. for the various users on the W7 client resides on a separat server.
> I've tried various suggestions found in the lists, but with no success.
> Obviously, there is a solution to my problem, but I'm struggling to find
> the right one.

It's in front of your eyes.
Don't you see it?

>      mkpasswd -l [-d] > /etc/passwd
>      mkgroup  -l [-d] > /etc/group

I wish it was that simple...

As I said, I've tried various solutions (you'll find several posts around the topic in the list) but non of them seem to solve my problen. meaning:

mkpasswd -l -d > /etc/passwd


mkgroup  -l -d > /etc/group

(or using any other flags) does not make any difference...


More information about the Cygwin mailing list