Problem redirecting stderr to pipe in subprocess

Tue Oct 11 10:24:00 GMT 2011

Christopher Faylor-8 wrote:
> On Mon, Oct 10, 2011 at 10:43:42PM -0400, Ken Brown wrote:
>>My STCs still don't work right for me under the 2011-10-10 snapshot. 
>>The bash subprocess no longer shows as stopped when I run ps, but it 
>>doesn't produce any output either, and it doesn't terminate for several 
>>minutes.  I eventually get the following message on the terminal
>>       1 [main] bash 7604 sig_send: wait for sig_complete event failed, 
>>signal -39, rc 258, Win32 error 0
>>and bash leaves a stackdump.  Are you seeing something different?
> For me it works on Cygwin the same as it does on Linux.  No hang,
> obviously.  If it worked like the above I wouldn't have announced
> a fix.
> cgf
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Then I'll put more words what I meant saying "External conditions might play
its role."

For example, a problem might appear to be fixed when cygwin1.dll restarted,
also depending
on whether and how rebase/rebaseall was applied.
This is particularly true for well-known (among developers) fork-related
This however might not(?) be fork-related.

I think there is a single occasion when __SIGFLUSHFAST (-39) is sent -- in
Is it right after inicialisations ? (When exactly? -- I do not understand).
Certainly it is before bash -ci ls  opens /dev/tty.


View this message in context:
Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list