setup.exe: force installation of specific package versions?

Andrew Schulman schulman.andrew@epamail.epa.gov
Wed Oct 5 16:01:00 GMT 2011


I run setup unattended as e.g.

setup.exe --quiet-mode --packages aria2,atool,autoconf,...

This works great, except for one thing:  There are some packages for which
the "current" versions are broken, at least for me, so I want to keep the
"prev" or some other already-installed version of the package.  Is there a
way to specify in the setup invocation that I want a particular version of
a particular package?

For example, I'd like to write

setup.exe --quiet-mode --packages bzr=2.3.1-1,openssh=prev,...

I've tried to run that, but it doesn't work - everything between the = and
the next comma is ignored.  So the current versions of those packages
always get installed.

Is there a way to do this that's not documented yet?  If not, is there any
inclination to add it?

Thanks,
Andrew.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list