mintty fonts (was: Re: setup and mintty)

Andy Koppe
Wed May 25 19:49:00 GMT 2011

On 25 May 2011 19:05, Ryan Johnson wrote:
>>> How do you get mintty to see Liberation Mono? I downloaded the family
>>> from
>>> redhat, installed it on my w7-x64 machine, made sure it was set to
>>> 'show,'
>>> and started a fresh mintty, but it still can't find the font.
>> Works for me, on w7-x64. Make sure the font shows up in the Fonts
>> control panel and that it isn't hidden, i.e. not appearing greyed out.
>> There's a 'Show' button along the top of the panel in case it is.
> I tried to say before that I have done that (I saw the closed bug about this
> and made sure to follow the instructions there). Unchecking that setting
> about language-specific hiding made a whole bunch of other (presumably
> Asian) fonts show up in mintty, but still no Liberation Mono.

I actually wasn't talking about that option, but the abilily to
show/hide each font separately. But it doesn't sound like that's the
issue anyway.

> The font is officially installed, officially showing, and usable by just
> about everything except mintty. Most apps (like Word) picked it up
> immediately.

Right, I'm afraid that leaves me stumped, given it's fine here. Do you
fancy messing with the mintty source code to see which flag on
ChooseFont() is excluding that font? It's in select_font() in
winctrls.c. I guess CF_FIXEDPITCHONLY is the prime candidate.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list