Cygwin 1.7.x on Windows 7: Exit statuses of Win32 executables are sometimes wrong

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Wed May 25 14:20:00 GMT 2011


On Wed, May 25, 2011 at 10:16:03AM -0400, Edward Lam wrote:
>On 29/04/2011 2:35 PM, John Dong wrote:
>> Reproducing this seems nondeterministic -- sometimes I can get it to
>> happen in 5 minutes, other times it takes overnight. I've tried using
>> a different shell (like dash), but it doesn't make a difference,
>> leading me to suspect this to be a lower-level issue within the
>> Cygwin DLL. It also seems to not happen for non-zero exit codes (e.g.
>> checking that exiter.exe 1 returns 1 always seems to succeed), though
>> I'm not 100% confident that I've tested this thoroughly enough.
>>
>> Again, I've not been able to reproduce this under Windows XP using
>> any version of Cygwin, but I have been able to reproduce it on both
>> 32-bit and 64-bit Windows 7. I'm not running anything special on this
>> machine -- it's a fresh install of Windows 7 Professional, just with
>> Cygwin installed.
>
>FWIW, we've been running into this as well. It appears to NOT be a 
>problem with Cygwin 1.5 on Windows 7. It only started happening on 
>Cygwin 1.7. As a result, we haven't had a reliable Windows 7 build 
>machine for a while now because we use a Cygwin gmake process that 
>compiles with MSVC.

As always: http://cygwin.com/acronyms#PTC

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list