Error building run2 from source package in win7

Charles Wilson
Tue May 24 21:10:00 GMT 2011

On 5/24/2011 3:53 PM, David Sastre wrote:
> On Tue, May 24, 2011 at 02:59:11PM -0400, Charles Wilson wrote:
>> A-ha!
>> Don't set -Werror as part of $CC, set it in $CFLAGS instead.
> Which is what is defined in the *.cygport's src_compile func:
> src_compile() {
>         cd ${S}
>         cygautoreconf
>         cd ${B}
>         cygconf CFLAGS="-Wall -Werror"
>         cygmake
> }
> And I'm doing nothing but running 'cygport *.cygport all'.

Well, Eric is the real expert, and he says don't set the warning flags
until the cygmake line, so that's first.  However, I assume the
incantation above worked in the past for the original author of the
.cygport(5) file, so why's it breaking for you?

Second, why does the STC below not work for you, when it worked for me?

> for the same reasons (config.log):
> configure:2563: gcc -c -Wall -Werror  conftest.c >&5
> cc1: warnings being treated as errors
> conftest.c: In function 'main':
> conftest.c:38:10: error: 't' is used uninitialized in this function
> conftest.c:54:23: error: 'b' may be used uninitialized in this
> function
> configure:2563: $? = 1

Well, looking at my config.log, I too have:

configure:2498: checking for an ANSI C-conforming const
configure:2563: gcc -c -Wall -Werror  conftest.c >&5
configure:2563: $? = 0
configure:2570: result: yes

but we already know that this conftest.c is not -Wall -Werror clean --
or, at least, that YOUR conftest.c is not clean.

Digging deeper in my configure, I find that the test uses the shell
function ac_fn_c_try_compile(), and that shell function has an
interesting bit of code:

1340      test -z "$ac_c_werror_flag" ||
1341      test ! -s conftest.err
1342        } && test -s conftest.$ac_objext; then :
1343   ac_retval=0's checking something to do with a Werror flag!  Maybe there's
a workaround, but (a) is only activated if the -Werror is in CFLAGS, not
CC -- otherwise *I* would have passed the STC with CC='gcc -Wall
-Werror' but I didn't, and (b) its only present in specific (newer?)
versions of autoconf, and you and I are using different versions.

Here's the first 3 lines of my configure script:

   1 #! /bin/sh
   2 # Guess values for system-dependent variables and create Makefiles.
   3 # Generated by GNU Autoconf 2.68.

What's yours say?


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list