Issues with latest rtorrent under Win7 x64 when attempting to package

Chris Sutcliffe ir0nh34d@gmail.com
Fri May 20 16:51:00 GMT 2011


On 20 May 2011 01:44, Christopher Faylor wrote:
> On Thu, May 19, 2011 at 10:01:47PM -0400, Chris Sutcliffe wrote:
>>Creating a debug build hasn't helped either.  When it crashes it's
>>causing a stack dump, so doing a 'bt' in gdb just returns 'no stack'.
>
> That probably means that it's forking.  You're debugging the parent
> when the child is having problems.
>
> The addresses in the stack dump can be decoded with gdb:
>
> l *0xnnnnn
> ^
> that's an "ell".

I've tried l *0xnnnn for each of the addresses in the stack dump:

Stack trace:
Frame     Function  Args
0028C77C  76D51A2C  (00000002, 7EFDE000, 00000000, 0000002F)
0028C798  76D54238  (00000002, 0028C7F0, 00000000, 0000002F)
0028C908  610BF0DD  (0028CA1C, 0028C980, 0028C960, 0028C940)
0028CA68  610BF7C0  (00000001, 020D9680, 020D96A0, 020D96C0)
0028CAB8  610C3545  (020D79F8, 0000B5F5, 00000000, 020EC060)
0028CD28  00405AA8  (61244184, 00000000, 0028CD68, 61007038)
0028CD68  61007038  (00000000, 0028CDA4, 61006980, 7EFDE000)
End of stack trace

Each time I get:

No source file for address 0xnnnnnn.

I've tried both the Frame and Function addresses.

Chris

-- 
Chris Sutcliffe
http://emergedesktop.org
http://www.google.com/profiles/ir0nh34d

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list