Fwd: octave updated to 3.4.0-3. Please test (strcat error)

Jeffrey Kletsky jkletsky@guidewire.com
Fri May 13 16:46:00 GMT 2011


This is a problem on Windows 7 Enterprise, 64-bit; cygwin 1.7.9-1; octave 3.4.0-3

Reinstalling Octave does not resolve
rebaseall does not resolve

Any suggestions on how to resolve?

TIA,

Jeff



$ uname -a
CYGWIN_NT-6.1-WOW64 JKLETSKY-T41 1.7.9(0.237/5/3) 2011-03-29 10:10 i686 Cygwin

$ octave
GNU Octave, version 3.4.0
Copyright (C) 2011 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.

Octave was configured for "i686-pc-cygwin".

Additional information about Octave is available at http://www.octave.org.

Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html

Read http://www.octave.org/bugs.html to learn how to submit bug reports.

For information about changes from previous versions, type `news'.

octave:1> plot([1 2 3], [1 2 3])
error: Invalid call to strcat.  Correct usage is:

-- Function File:  strcat (S1, S2, ...)

error: called from:
error:   /usr/share/octave/3.4.0/m/help/print_usage.m at line 87, column 5
error:   /usr/share/octave/3.4.0/m/strings/strcat.m at line 92, column 5
error:   /usr/share/octave/3.4.0/m/plot/__gnuplot_get_var__.m at line 113, column 11
error:   /usr/share/octave/3.4.0/m/plot/__go_draw_axes__.m at line 40, column 18
error:   /usr/share/octave/3.4.0/m/plot/__go_draw_figure__.m at line 167, column 19
error:   /usr/share/octave/3.4.0/m/plot/__gnuplot_drawnow__.m at line 86, column 5
octave:2> quit
terminate called after throwing an instance of 'octave_interrupt_exception'
panic: Aborted -- stopping myself...
attempting to save variables to `octave-core'...
save to `octave-core' complete
Aborted (core dumped)


On Fri, Apr 8, 2011 at 5:51 AM, Christopher Faylor  wrote:
> On Thu, Apr 07, 2011 at 06:24:31PM -0400, Stan wrote:
>>On Wed, Apr 06, 2011 at 10:05:24AM -0400, Christopher Faylor wrote:
>>> On Wed, Apr 06, 2011 at 03:54:05PM +0900, Tatsuro MATSUOKA wrote:
>>> >Hello
>>> >
>>> >I have confirmed that octave-3.4.0-3 fails to plot on cygwin 1.7.9-1 but not 1.7.8-1.
>>>
>>> We don't need confirmation that octave doesn't work. ?We need to know if
>>> rebasing works around the problem.
>>
>>Here on Win 7 64bit I have:
>>$ uname -a
>>CYGWIN_NT-6.1-WOW64 darkstar 1.7.9(0.237/5/3) 2011-03-29 10:10 i686 Cygwin
>>
>>Cygwin Package Information
>>Package ? ? ? ? ? ? ?Version ? ? ? ?Status
>>cygwin ? ? ? ? ? ? ? 1.7.9-1 ? ? ? ?OK
>>octave ? ? ? ? ? ? ? 3.4.0-3 ? ? ? ?OK
>>gnuplot ? ? ? ? ? ? ?4.4.0-1 ? ? ? ?OK
>>
>>
>>I did rebaseall and I still get the error:
>>
>>octave:1> t = 0:2*pi/100:2*pi;
>>octave:2> plot(t,sin(t))
>>error: Invalid call to strcat. ?Correct usage is:
>>
>> -- Function File: ?strcat (S1, S2, ...)




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list