GNU screen on Cygwin: Cannot seem to reattach, no matter what I try

Andrew Schulman schulman.andrew@epamail.epa.gov
Thu May 12 15:11:00 GMT 2011


> Hi Andrew and Corinna,
> 
> Yep, something about FAT32 appears to be the problem.  As Corinna correctly
> notes, permissions are faked on FAT32.  Doesn't matter what chmod I run, it's
> all 644 or 755.  Apparently, GNU screen does not like this, but apparently it
> also doesn't give any error message that that's the problem.  Might be worth
> adding a few lines to the source to provide somewhat more diagnostic error
> messages re: when socket files cannot be found or opened?!?

Yes.  After screen creates the socket for a new session, it should check
whether the permissions it tried to set really got set, and if they didn't,
warn the user that s/he won't be able to reattach.  Then when it tries to
reattach, if it won't because the permissions are too loose, it should tell
the user that instead of just saying "There is no screen to be resumed."
Maybe it could even provide a way to forcibly override the permission
check, and let the user connect insecurely if they want to.

I'll work on this whenever I have a spare hour or two.  Meamwhile, I'll put
a warning about it into README.Cygwin.

> At any rate, it works great now -- thanks!!!  I set SCREENDIR=/cygdrive/c/tmp
> (an NTFS volume).  Bingo, I can reattach.  From same tty or different tty,
> whether console or remote.  It's just like the old SCO Xenix days with Wyse 60
> terminals -- woo-hoo!  :)  Only I'd take SCO Xenix over cmd.exe any day. :)

Yay!  I love a problem solved.  Happy screen-ing.
Andrew.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list