Emacs backgrounds itself

Ryan Johnson ryanjohn@ece.cmu.edu
Thu May 5 14:38:00 GMT 2011


s/gcc/gdb/g   *sigh*
On 05/05/2011 10:34 AM, Ryan Johnson wrote:
> Hi all,
>
> Strange one here... I just updated emacs and a bunch of other 
> packages, and for some reason 'emacs -nw' now backgrounds itself 
> immediately after starting, and again each time I try to foreground it 
> afterward. If I run emacs-X11 directly (again, in -nw mode) it 
> segfaults during startup, but I haven't been able to catch it in the 
> act using gcc (it seems to load properly under gcc but keyboard 
> handling is worthless). Cygcheck output is attached.
>
> I've tried running a home-built emacs-23.3.1 and it behaves the same 
> way; running the same home-built binary against an older install I 
> happened to have laying around works normally, so some library update 
> must be the culprit. To help narrow things down a bit, a diff of old 
> vs. new cygcheck outputs is also attached.
>
> Any ideas?
> Ryan
>


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list