[ANNOUNCEMENT] Updated: mingw-{xz/liblzma-devel}-5.0.2_20110517-1; NEW: mingw-liblzma5-5.0.2_20110517-1

Charles Wilson cygwin@cwilson.fastmail.fm
Thu Jun 2 05:09:00 GMT 2011


The mingw-xz package provides a version of the xz compression 
library and tools built using the standard windows runtime library
and NOT cygwin. It is used by setup.exe and is provided specifically
for that purpose. No other uses are supported. However, for testing
purposes it does provide mingw versions of the following tools:
xz.exe, xzdec.exe, lzmadec.exe, and lzmainfo.exe in addition to the
libraries and headers needed for setup.exe development (these apps
are installed into /usr/i686-pc-mingw32/sys-root/mingw/bin, and not
into /usr/bin).

The xz package is the successor to lzma.  Its command-line tools
support both .lzma files and the new .xz format. The xz package provides
a new runtime library: liblzma supports encoding as well as decoding,
both .lzma and .xz streams.

[[ compiled using mingw-gcc-4.5.2 ]]

!!!!!!!!!!!!!!!!!
!!!! WARNING !!!!
!!!!!!!!!!!!!!!!!
IF you are attempting to update an existing cygwin installation, which
has the gcc-mingw 'add-on' packages installed (*), then you MUST
upgrade the gcc-mingw packages to version 20050522-3 or newer, before
installing this upgrade.  Do NOT attempt to upgrade BOTH gcc-mingw and
this package during the same setup.exe event. The reason for this
restriction is fairly complex, and is detailed here:
    http://cygwin.com/ml/cygwin-announce/2011-04/msg00015.html

If you are reading this announcement AFTER having messed up your cygwin
installation, because you didn't follow these instructions or didn't
know about them, then see the section in this message
    http://cygwin.com/ml/cygwin-announce/2011-04/msg00015.html
that begins with "HELP!!!" and follow the suggestions there to "fix" it.

(*) gcc-mingw packages are "add-ons" to the gcc-3 compiler suite, and
    provide the necessary files for the -mno-cygwin mode of that
    compiler.

**************
*** NOTE 1 ***
**************
If you have installed the "missing" mingw cross compiler packages from
   http://cygutils.fruitbat.org/ITP/mingw-gcc/
then you need take no special action.  This package will simply upgrade
the cygutils.fruitbat.org one.

**************
*** NOTE 2 ***
**************
After upgrading all of the various mingw-packages (that is,
mingw-{runtime,zlib,bzip2,xz,gpg-error,gcrypt} etc.), the following
directories may be empty:
  /usr/include/mingw
  /usr/lib/mingw
This is expected.  Those 'gcc-3 -mno-cygwin' users who wish to continue
rather than switching to the new MinGW cross compiler, may find it
necessary to add -I/usr/i686-pc-mingw32/sys-root/mingw/include when
compiling and -L/usr/i686-pc-mingw32/sys-root/mingw/lib when linking.
However, another workaround for gcc-3 users is to remove the now empty
/usr/{include,lib}/mingw directories and replace them with symbolic
links:
  rmdir /usr/include/mingw
  ln -fs /usr/i686-pc-mingw32/sys-root/mingw/include /usr/include/mingw
  rmdir /usr/lib/mingw
  ln -fs /usr/i686-pc-mingw32/sys-root/mingw/lib /usr/lib/mingw


CHANGES (since 4.999.9beta-11)
==============================
o Update to 2011-May-17 git snapshot
  Tue May 17 12:26:28 2011 +0300
  841dc1f891b48b23f84c0f0e0c86c7c4e4bdcdf5
  - contains a few fixes and back-compatibility corrections, relative
    to the official 5.0.2 source distribution
o Recompiled by, and repackaged for use with, the i686-pc-mingw32
  cross compiler.
o Changed the name of the DLL from mgwlzma-1.dll to liblzma-5.dll,
  for compatibility with mingw.org distribution (and because the
  upstream SONAME changed to '5', to coincide with the official
  non-beta release).
o Upstream changes:
  - memory usage limits are disabled by default (use --memory=...)
  - XZ_DEFAULTS variable is now supported
  - new 'xz --list' option (use --verbose repeatedly for detailed output)
  - fixed memory leak
  - fixed encoding issue with "empty blocks"
  - documentation improvements
  - bump soname to 5.0.2 (dllname = 5)
* Bump DLL package to "5" to match dllname of post-5.0 releases.
* Applicatons (xz, xzdec) are now dynamically linked to liblzma-5.dll
  rather than statically linked. (They already requied the dynamic
  library libgcc_s-dw2-1.dll, so they weren't REALLY static anyway).
  - Also, apps no longer renamed to 'mingw-*' because they are now
    installed into the i686-pc-mingw32 sys-root, rather than /usr/bin.

-- 
Charles Wilson
volunteer mingw-xz maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link
on the http://cygwin.com/ web page.  This downloads setup.exe to
your system.  Then, run setup and answer all of the questions.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com@cygwin.com

If you need more information on unsubscribing, start reading here:

http://sourceware.org/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is
available starting at this URL.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list