cygwin 1.7.5 psql does not run

Gabor Kincses npure2001@yahoo.com
Wed Jun 1 22:10:00 GMT 2011


Reini Urban <rurban <at> x-ray.at> writes:

> 
> David Einstein schrieb:
> > Windows 7 64 bit
> > When I run the cygwin provided psql it immediately returns.  Even if I
> > run 'psql --help' or 'psql -v'.
> >
> > I tried recompiling postgres from source, and got the same behavior.
> >
> > All the dlls seem to be in place.
> 
> Oops. You've got two postgresql installations, cygwin and the native one
> C:\cygwin\bin\psql.exe
> C:\Program Files (x86)\PostgreSQL\8.4\bin\psql.exe
> 
> Shouldn't be a problem,
> but you've also got much different dependencies than me.
> I'm on XPSP3, 32-bit only, but I can try in work on Win7/32-bit.
> 
[output deleted]
> 
> > I have attached the output of
> > cygcheck -s -r -v
> > in cygcheck.out and the output of
> > cygcheck psql
> > cygcheck_psql.out


There appears to be a problem with package dependencies:

cygldap-2-3-0.dll is missing and openldap must be installed manually in the 
latest version I have:

$ uname -srv
uname -srv
CYGWIN_NT-6.0-WOW64 1.7.9(0.237/5/3) 2011-03-29 10:10

BTW, why does the FAQ say that there is no single cygwin version?  Can somebody 
please put uname -srv in the FAQ???

Thanks,
Gabor




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list