Cygwin shells closing when launched by a telnet server client in Windows 7

Clayton Evans
Mon Aug 22 18:46:00 GMT 2011

I am in the process of upgrading to a new machine.  This machine is used as a compute server, where users telnet to the machine, start up a Korn shell and run compute intensive programs from the Korn shell.  The current machine is running Cygwin 1.5 and Windows XP 64 bit.  This process has worked for years.  The new machine is running Cygwin 1.7 and Windows 7 64 bit.  After telneting to the new machine, mksh.exe appears to start after some pause, show it's prompt and then exits, returning to the command prompt within the telnet session.  This behavior makes me think that no input stream is getting connected to the shell and the shell exits.
Both machines are using Microsoft's Telnet Service.  I have tried ash.exe, bash.exe, dash.exe and sh.exe.  All the shell programs show their input prompt and then exit to the command prompt
C:\cygwin\bin>mksh.exe -l -i
user@hostname ~

The shell commands work fine, when one is locally on the compute server.   I have tried HyperTerminal, putty.exe and Microsoft's telnet client on the client machine and they all give the same result.
There are no entries in the Windows 7 event log.
The Korn shell is working non-interactively when telneted as demonstrated below by having the Korn shell execute a command specific to the Korn shell.
C:\cygwin\bin>mksh.exe -c "whence whence"

I have tried setting the Korn shell to be terminal server aware, peflags -tsaware=true mksh.exe, with no change in the results.

Clayton Evans

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list