SSHD Issue Windows 2003 64 bit

Gary gary.mphelps@gmail.com
Fri Aug 19 21:59:00 GMT 2011


I've re-installed cygwin on a fresh virtual machine (offline install)
and have tried running:
'ssh-host-config' -- still no echo from the terminal
'cygrunsrv -S sshd'  -- cygrunsrv: Error starting a service:
OpenService:  Win32 error 1060:The specified service does not exist as
an installed service.
'net start sshd' -- The service name is invalid.  More help is
available by typing NET HELPMSG 2185.

My environment variables below:
Variable:Home
Value: C:\
Variable: Path
Value: C:\cygwin\bin
Variable:TEMP
Value: %USERPROFILE%\Local Settings\Temp
Variable:TMP
Value: %USERPROFILE%\Local Settings\Temp

I have re-created the passwd file and group file via our previous
conversations.  What other steps could I take to ensure SSHD to run as
a service on Windows Server 2003 r2 64bit?  Any other ideas?

> On 8/16/2011 6:25 PM, Gary wrote:
>>
>> Sounds good I'll take those steps;
>>
>> In the meantime my cygwin.bat file looks like this:
>> [at]echo off   (note: at sign removed because it was causing false
>> positives on an email filter)
>> CYGWIN=binmode tty ntsec
>> C:
>> chdir C:\Cygwin\bin
>>
>> bash --login -i
>
> FWIW, you don't need any of the values you've added to the CYGWIN
> environment variable.  They are all deprecated or will be in the cygwin
> 1.7.10 package.  Their existence, however, should not cause any problems.
>
> --
> Larry

-- 
Gary Phelps

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list