git-svn hang starting with 20110721 snapshot.

Corinna Vinschen corinna-cygwin@cygwin.com
Wed Aug 3 14:56:00 GMT 2011


On Aug  3 10:00, Christopher Faylor wrote:
> On Wed, Aug 03, 2011 at 09:45:28AM -0400, Christopher Faylor wrote:
> >On Wed, Aug 03, 2011 at 10:44:27AM +0200, Corinna Vinschen wrote:
> >>On Aug  2 10:58, David Rothenberger wrote:
> >>> I use git-svn extensively in my day-to-day work, and I noticed with
> >>> recent snapshots that some of the git-svn commands are hanging. I
> >>> narrowed it down to the 20110721 snapshot. 20110713 is the last one
> >>> that works fine.
> >>> 
> >>> I realize this isn't exactly a STC, but I don't have the time right
> >>> now to narrow it down further (or the skills, really). I've attached
> >>> a script which reproduces the problem. It requires svn and
> >>> git-svn. In the script, the first "git svn init" command hangs with
> >>> 20110721, but the entire script succeeds with 20110713.
> >>> 
> >>> I hope this is enough information to track down the problem, because
> >>> I was absolutely LOVING the speed increase in 20110801.
> >>
> >>This is not enough for me.  I tried your script on W7 32 bit and Server
> >>2008 R2 64 bit, using Cygwin from CVS as well as the 20110801 snapshot,
> >>in in no case can I reproduce a hang.  The script runs fine (and fast):
> >
> >I don't see a hang but I do see a:
> >
> >error: cannot fork() for git-svn: Resource temporarily unavailable
> >
> >I'll investigate that.  Maybe it's related.
> 
> Huh.  I ran rebaseall before reporting the above but, on inspecting the
> output from strace, I saw that dlls were getting located in non-rebased
> locations.  So, I ran rebaseall again.  *Now* I see the hang.  Weird.
> 
> So I guess I can investigate the actual problem now.  FWIW, strace
> reports that the child of a fork has died with a SIGSEGV but I don't see
> the location of the SIGSEGV in the strace output.  So it will be a
> little tricky to track down.

Is git-svn using perl?  I have constant problems using perl after a 
rebase.  The problem starts with perl.exe(!) being rebased(!) to
0x50000000(!).  However, when rebasing perl.exe to 0x400000 where it
belongs, it doesn't work either.  Only reinstalling perl helped
afterwards.

Reini, could you please update the perl package so that the executable
is in its default place at 0x400000?


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list