bash-4.2 and symlink to folder that turns to be not executable

Denis Excoffier
Tue Aug 2 06:33:00 GMT 2011

On Tue, Aug 02, 2011 at 07:53:44AM +0159, Denis Excoffier wrote:
>> On Mon, Aug 01, 2011 at 07:02:48PM +0200, Corinna Vinschen wrote:
>> >> 
>> >> Ouch.  I made a mistake in a bracket term in faccessat.  Fixed in CVS.
>> >> Thanks for following up with more testing.
>> I tried to compile the cygwin sources and it failed because
>> bfd.h is not found (in Since asection is used everywhere
>> in this file, it seems needed. I use the last binutils-2.21.53-1
>> which does not contain usr/include/bfd.h while the previous
>> binutils-2.20.51-2 had it.
>> I am currently trying with the last binutils and the additional
>> bfd.h (and ansidecl.h, symcat.h, dis-asm.h, bfdlink.h) poked in
>> my /usr/include.
>> Seems strange that bfd.h is missing since /usr/share/info/
>> documents it.
>> Denis Excoffier.

The compilation worked well (with GCC 4.3.4), last access times
shows that bfdlink.h and dis-asm.h were not used.
Also, the original problem has disappeared.

Thank you.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list