[ANNOUNCEMENT] Updated: vim-7.3.003-1

Thorsten Kampe thorsten@thorstenkampe.de
Fri Aug 20 14:33:00 GMT 2010


* Thorsten Kampe (Fri, 20 Aug 2010 15:38:26 +0200)
> I reinstalled vim and got the exact same message again ("Unable to 
> extract /usr/bin/vi -- the file is use."). A simultaneous process 
> monitor log shows that CreateFile operations result in "DELETE PENDING" 
> ("Desired Access: Read Control, Disposition: Open, Options: Open Reparse 
> Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: 
> n/a"). Clicking two times on Retry (without changing anything else) 
> let's the installation continue.
> 
> I ran Process Explorer and it looks like zsh has handles open to vi, 
> vim, view and vimdiff - although these executables are definitely not 
> running.

Okay, coming closer (and getting weirder):
"type jed"[1] creates handles to vi, vim, view and vimdiff (but not in 
bash). Zsh is the latest available one via setup.exe (zsh 4.3.10-dev-2).

It still doesn't explain why only the creation of the symlinks (vi and 
ex) fails and not the replacement of vim itself.


Thorsten
[1] Part of...
"type jed &> /dev/null && DEFAULT_EDITOR=jed || DEFAULT_EDITOR=vim"
...im my .zshrc


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list