[ANNOUNCEMENT] Updated: vim-7.3.003-1

Steve Holden steve@holdenweb.com
Fri Aug 20 14:15:00 GMT 2010

On 8/20/2010 9:38 AM, Thorsten Kampe wrote:
> * Corinna Vinschen (Fri, 20 Aug 2010 14:37:08 +0200)
>> I just created a FAT32 partition on W7 and did a base install
>> including vim. Then I started setup again and reinstalled just the vim
>> package. That worked fine as well. So it has nothing to do with the
>> FS, nor with the OS.
> I reinstalled vim and got the exact same message again ("Unable to 
> extract /usr/bin/vi -- the file is use."). A simultaneous process 
> monitor log shows that CreateFile operations result in "DELETE PENDING" 
> ("Desired Access: Read Control, Disposition: Open, Options: Open Reparse 
> Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: 
> n/a"). Clicking two times on Retry (without changing anything else) 
> let's the installation continue.
> I ran Process Explorer and it looks like zsh has handles open to vi, 
> vim, view and vimdiff - although these executables are definitely not 
> running.
The shell has probably cached them to speed up command lookup and dispatch.

Steve Holden           +1 571 484 6266   +1 800 494 3119
DjangoCon US September 7-9, 2010    http://djangocon.us/
See Python Video!       http://python.mirocommunity.org/
Holden Web LLC                 http://www.holdenweb.com/

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list