ImageMagick: Still more insufficient package dependencies?

Angelo Graziosi angelo.graziosi@alice.it
Thu Aug 19 11:34:00 GMT 2010


I am trying to build the development version of Emacs with the 
imagemagick support. In the configure step one gets:

$ ./configure --with-imagemagick
[...]
checking for Wand... yes
checking IMAGEMAGICK_CFLAGS... -fopenmp -I/usr/include/ImageMagick
checking IMAGEMAGICK_LIBS... -lMagickWand -lMagickCore
checking for MagickExportImagePixels... no
[...]
Does Emacs use imagemagick?                             yes
[...]

But,

$ make
[...]
image.o: In function `imagemagick_load_image':
/tmp/emacs/src/image.c:7723: undefined reference to 
`_MagickExportImagePixels'
collect2: ld returned 1 exit status
make[2]: *** [temacs.exe] Error 1
make[2]: Leaving directory `/tmp/emacs/Work/src'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/tmp/emacs/Work'
make: *** [bootstrap] Error 2

So, is this to be expected with current ImageMagick packages of Cygwin? 
or have we another 'more insufficient package dependencies' issue? In 
this case, which are the other packages to be installed?

I have already installed ImageMagick-6.4.0.6-2, 
libImageMagick1-6.4.0.6-2 and libMagick-devel-6.4.0.6-2 and their 
dependencies.

Thanks,
Angelo.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list