Problem with -D_GLIBCXX_DEBUG and cppcheck

Cary R.
Fri Aug 13 18:07:00 GMT 2010

On my Linux machine I'm using the latest cppcheck from git
since it has bug fixes I need to test my code. Now that it's
mostly working I tried to compile it on Cygwin so I would
have it available there as well. I ran into a few problems
and after some debug it appears to be a problem with the
-D_GLIBCXX_DEBUG flag. My cppcheck bug report for this can
be found here:

I'm not a cppcheck maintainer so I can't provide much more
help than submitting this report. This is using the latest
Cygwwin running on Windows XP Pro SP 3 32 bit.

CYGWIN_NT-5.1 cdr-laptop 1.7.5(0.225/5/3) 2010-04-12 19:07 i686 Cygwin

g++ (GCC) 4.3.4 20090804 (release) 1

If you need more information please let me know. You should
be able to reproduce the test crash just by compiling and
testing (make test) the latest code from git (git clone
git:// since it has the
-D_GLIBCXX_DEBUG flag already set. This has not been noticed
with the actual releases on Cygwin since cppcheck only uses
that flag during development.



Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list