bash postinstall script returns an error
Fri Aug 13 00:14:00 GMT 2010

I was going to mention, but I see there's already a thread 
for that, so I'll move right on to the next one.

When I run setup.exe I always get an error for the postinstall 
script, it seems to be on the line of:

/bin/test -e /dev/stdin  || ln -s /proc/self/fd/0 /dev/stdin  || result=1

I'm not so clear as to why this fails. test returns a status of 1 when 
the script is run by the installer, and yet /dev/stdin does exist. 
setup.log.full contains a predictable "ln: creating symbolic link 
`/dev/stdin': File exists".

If I run the postinstall script manually, test gives a status of 0, 
stdin is left alone and the script runs to the end successfully - it 
only fails when run from inside the installer (2.712) for me. I've tried 
invoking bash for the script using the same switches as those reported 
in setup.log.full, but it still runs fine when done manually.

If I remove /dev/stdin /dev/stdout and /dev/stderr the installer runs 
through fine.

The result isn't a big problem since the files exist, but it does seem odd.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list