1.7.5: Hangs with tcsh pipes (was: 1.7.2: hangs with tcsh pipes)

Stefan Merten smerten@oekonux.de
Fri Aug 6 17:56:00 GMT 2010

Hi Cygwin hackers!

4 months (122 days) ago Stefan Merten wrote:
> Since recently I used some Cygwin 1.5 version. This worked very well.
> Lately I switched to Cygwin 1.7.1 and ran into a problem described
> below. I switched to Cygwin 1.7.2 hoping that my problem is solved but
> unfortunately this is not the case.
> Since the switch to Cygwin 1.7 I have a strange problem with my
> `tcsh`. I'm using an extensive startup script which hangs
> occasionally. I added `set echo` so I was able to identify the spots
> where the occasional hangs occur.
> I isolated the problem into the appended script. Sometimes it runs
> fine and sometimes it hangs in one of the commands. You should be able
> to run
>   tcsh -f tcsh_problems.csh
> My guess is that it has to do with the pipes used in the commands
> executed. When a hang occurs one or more of the commands in the
> pipeline are not shown to be executed. In any case I had this problem
> only for commands which involved pipes. If I understood the release
> notes correctly then pipe handling has been changed since 1.5.

Meanwhile I upgraded to 1.7.5. The problem still occurs but it is much
rarer now.

> I added the output of `cygcheck -svr`. I had to remove some
> information for privacy reasons, however. Important information:

I added it for my current installation.

I hope this information is helpful for you.



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck-svr.out
URL: <http://cygwin.com/pipermail/cygwin/attachments/20100806/5738881d/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 306 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20100806/5738881d/attachment.sig>

More information about the Cygwin mailing list