strace on a2ps complains about \Device\Harddisk4\DR4

Rasputin Paskudniak rpaskudniak@yahoo.com
Mon Aug 2 11:34:00 GMT 2010


On 7/26/2010 11:20 PM, René Berber wrote:
> Rasputin Paskudniak wrote:
>
> [snip]
>> I have a new Windows-7 64-bit box and Cygwin (1.75) was my first
>> download.  At the installation stage, I included a2ps (4.13).
>>
>> My problem: When I run it, I just get back to my shell prompt. This is
>> even when I run "a2ps -- version".  Mystery?
>
> No mystery, but...
>
>> First step: What is the exit code?  echo $? displays 127. (errno.h tells
>> me this is related to sockets.  Highly unlikely.)  So I decided to run
>> it with strace:
>
> ... you followed the wrong procedure.
>
> To get the error description you do:
>
> $ net helpmsg 127
>
> The specified procedure could not be found.
>
> That usually means the program, a2ps, can't find one or more of the
> dynamic libraries it needs.
>
> To find what libraries are missing use: cygcheck `which a2ps`
>
> [long snip]
>
> Instead of strace, another tool would be better in this case, its not
> from Cysgwin but from Microsoft, it's SysInternals depends.  It will
> tell you the same as the cygcheck.

Rene,

Thanks much for these two tidbits.  I had not hear of the "net helpmsg" 
command and I have not gotten around to installing any sysinternals 
utilities.  But since I had known of this one (depends) I would not have 
pulled it down anyway.

Very much thanks to Dave and Rene for these insights.
-- 
+- Rasputin Paskudniak -----------------------------------+
|- In perpetual pursuit of undomesticated aquatic avians -|
+---------------------------------------------------------+


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list