Building against Stripped DLLs

Christina McQuirk
Sun May 31 05:52:00 GMT 2009


I am working on a OpenGL project in gcc, cygwin.  I keep getting the
error -lglu32 not found when I run make.  I did a search through
google/cygwin archives and found that I need to be using UNIX static
library files something like .a or .dll.a instead of the.dll files I
currently have.  (As a note, I did install cygwin through setup.exe
and I have all the devel tools installed and have updated through

Since I do not have the source or import library files, I tried
Linking against DLLs at described here:
cygwin dot com slash cygwin dash ug dash net slash dll
(bottom of the page).

I recieved the equivalent message of [Note that this will only work if
the DLL is not stripped. Otherwise you will get an error message: "No
symbols in foo.dll".] for my files.  So I get a .def file for the dll,
but there is nothing in it, so I cannot make it a .a import library.

Is there a way to turn these stripped files into .a files?  Or, can I
get the source code somewhere?  The files I am having trouble with are
-lglu32, -lglut32, -lopengl32, -lkernel32.  I have the dlls in my
system32 folder, but I do not have import library version.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list