Cygwin postinstall scripts / bash [ ] syntax fails on Win 2003 x64 / Xen
Sun May 31 05:30:00 GMT 2009

Hello all,

First time writing to this list, forgive me if this is redundant but I  
have spent many hours researching this issue and while it seems to be  
at least a known issue, I can't find any evidence it has been addressed.

The best thing I can do is point you to this post, it is quite telling:

I am not using "KVM", but I am using Windows 2003 x64 on Xen, and I am  
having the same issue. Cygwin fails to run the postinstall scripts,  
and this leaves the environment all but unusable. It comes down to the  
fact that bash cannot execute the "test" or "[ x ]" syntax without  
throwing a segmentation fault. Running [ 1 ] at the bash prompt  
immediately reproduces the bug. The bash prompt can be loaded, but non  
of the startup scripts are executed and I just get a bash-3.2$ prompt  
in /usr/bin.

The people who posted at the above link wrote a patch that supposedly  
solved the problem, but there is no way for a normal user to try this  
without a compiler and it doesn't appear to be in the release Cygwin  
code yet. I also tried the Cygwin 1.7 beta and have the same problem.

I am an experienced Cygwin user of many years and dozens of solid  
installs. I often setup the sshd server for remote access to remote  
servers running Windows. This is the first time I have had these kinds  
of problems.

Any help would be appreciated, such as news about the status of this  
bug, how I can find more information about the issue, or if a fix is  
planned for a future release. This bug also appears as if it could be  
viewed as a Xen bug, but I'd like to understand what your position on  
that actually is.

Thank you,

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list