emacs -nw keypad

Ken Brown kbrown@cornell.edu
Wed May 27 01:58:00 GMT 2009


On 5/26/2009 4:03 PM, Eli Zaretskii wrote:
> It would really help me to see the result of typing "C-h l" after
> pressing the keypad keys, on Tim's machine, as I requested earlier
> in this thread.

I can't help you with Tim's machine, but I tried it on my own.  (I'm 
currently running emacs-23.0.94 in cygwin-1.7.)  It's clear that the 
keypad keys are not recognized as such when running emacs in rxvt or 
emacs -nw in an xterm.  The same thing happens in a third terminal that 
I tried, mintty.

In addition, emacs sees C-h as DEL in all three cases, so it isn't 
recognized as the help key.  I had to use F1 for help.

Here are the results.  First, for comparison, I ran emacs under X 
(without -nw).  With numlock on, I typed '123456' on the keypad, 
followed by C-h l.  The results were as expected:

	<kp-1> <kp-2> <kp-3> <kp-4> <kp-5> <kp-6> C-h l

Next, I tried the three terminals I mentioned above, typing '123456' on 
the keypad, followed by F1 l:

emacs -nw in xterm:   1 2 3 4 5 6 ESC O P l

emacs in rxvt-native:  1 2 3 4 5 6 ESC [ 1 1 ~ l

emacs in mintty:  1 2 3 4 5 6 ESC O P l

In the first and third cases, the environment variable TERM is xterm 
before starting emacs, and COLORMTERM isn't set.  In the second case, 
TERM=rxvt-cygwin-native and COLORTERM=rxvt-xpm.  In all cases, including 
the good case (emacs under X without -nw), TERM="dumb" within emacs, as 
shown by evaluating (getenv "TERM").

Ken

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list