emacs -nw keypad

Eli Zaretskii eliz@gnu.org
Wed May 27 01:12:00 GMT 2009


> Date: Tue, 26 May 2009 07:58:41 -0400
> From: Ken Brown <kbrown at cornell dot edu>
> 
> On 5/25/2009 6:13 PM, Jon TURNEY wrote:
> > I would have said that this could be same problem as in [1], an X server 
> > bug, but then I would expect the problem to be seen both in "emacs -nw 
> > in an xterm under X" and "emaacs under X"...
> 
> I'm not yet convinced that there's a bug.  The tpu-*.el files use the 
> emacs variable 'window-system' to decide whether X windows is running. 
> If I start emacs under X, that variable has the value x.  If I run emacs 
> -nw in an xterm, the variable has the value nil.  If I run emacs under 
> rxvt (without specifying -nw), I get the message
> 
> 	Display :0 unavailable, simulating -nw
> 
> and again window-system has the value nil.  This strikes me as the 
> correct behavior, consistent with the documentation of '-nw'.

Yes.

> I guess what's puzzling is why Tim doesn't have a problem with earlier 
> versions of emacs.  Has something changed in how emacs interprets -nw? 
> Or has tpu-edt changed?  Maybe Eli can clarify this.

Sorry, but I have no clue yet.  rxvt.el, the Emacs Lisp package that
supports rxvt, has undergone significant changes since Emacs 21.x, and
the Emacs 23 core includes significant changes in how text-mode
terminals are handled.  Perhaps one or more of these changes have
adverse effect on Cygwin.  Or it could be something in Tim's setup
or customizations.

It would really help me to see the result of typing "C-h l" after
pressing the keypad keys, on Tim's machine, as I requested earlier
in this thread.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list