Upgrade to cygwin 1.7 seemed to trash bash profile, path

Karl M karlm30@hotmail.com
Tue May 26 15:55:00 GMT 2009

> Date: Tue, 26 May 2009 11:29:15 -0400
> From: lh
> Subject: Re: Upgrade to cygwin 1.7 seemed to trash bash profile, path
> Aaron Humphrey wrote:
>> I've been having some intermittent problems lately with screen
>> hanging, when it hasn't before. This is on my home computer, which
>> was still running 1.5.25, and I've been using screen on 1.7 without
>> event on my work computer, so I decided to upgrade at home. I
>> downloaded setup-1.7, ran it, and went away. When I came back, it
>> seemed to have finished successfully.
>> Just now I tried to run it for the first time, clicking on the cygwin
>> icon to run cygwin.bat as usual. What I get is a window with
>> "bash-3.2$" at the top. This is not my usual prompt. I immediately
>> noticed, too, that PATH was not set, or rather that it didn't include
>> any Cygwin paths, only Windows. A look at my home directory showed no
>> .profile, .bash_profile, .bashrc, or anything.
>> I've been lurking on this list for long enough that I feel like I
>> should know what happened, but I confess I don't. Is it a problem
>> with the new /etc/fstab? Was it something trashing my startup files?
>> I've checked for undone postinstall scripts and found none; I tried
>> rerunning setup-1.7, then rerunning it and reinstalling base-files,
>> but to no avail. Of course, I have no convenient backups of my bash
>> setup files or anything.
>> Cygcheck -svr output attached. Let me know if setup.log.full would
>> come in handy or anything.
> You seem to be missing '/usr/bin' and '/usr/lib'. There was talk about
> some of this changing though in my up-to-date installation, I still have
> them so I'm not sure where this stands. In any case, it suggests that
> you may want to try add the following to your '/etc/fstab' file:
> c:/cygwin/lib /usr/lib some_fs binary 0 0
> c:/cygwin/bin /usr/bin some_fs binary 0 0
> If that doesn't work, maybe just try rerunning 'setup.exe' and select
> "Reinstall" for the "All" category.
This may be the same problem that the 2009-05-18 snapahot fixed for me.
For some users, sshing in did not have the above mounts, but other users
sshing in had them. Adding the mounts back to my fstab (as Larry mentioned
above) was also a workaround that worked for me.
Hotmail® has ever-growing storage! Don’t worry about storage limits.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list