Cygwin OpenSSH and Windows 7 RC

William Zhang
Thu May 21 07:09:00 GMT 2009

Hi All,

Have anybody tried Cygwin and SSH with Windows 7 RC x86 (Build 7100)?
 I saw there was a discussion some time in Jan about the Windows 7
Beta and it was reported that the basic stuff works fine including ssh
and sshd.
I just installed Windows 7 RC today and install the cygwin and
openssh. The basic functions like bash, vim.. works fine but I am not
able to ssh to this system from another linux box and here is output

$ ssh -v -v -v
OpenSSH_5.1p1, OpenSSL 0.9.8h 28 May 2008
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/root/.ssh/identity type -1
debug1: identity file /home/root/.ssh/id_rsa type -1
debug1: identity file /home/root/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host

It works for some time but most of this time it fails as above.  I
tried both the current release 1.5.25-15 and beta release 1.7 but got
the same results. Firewall and UAC are turned off in Windows.

Did anybody get luck to make it work on Windows 7 RC?


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list