Python enabled GDB (Archer) -Help

Sreejith sreejithsmadhavan@gmail.com
Tue May 19 10:34:00 GMT 2009


2009/5/19 Larry Hall (Cygwin) <reply-to-list-only-lh@cygwin.com>:
> On 05/16/2009, Sreejith wrote:
>>
>> This is probably because python development packages (Equivalent to
>> python2.5-dev deb package) are not installed. Unfortunately it is not
>> available for cygwin. Is there any other way to solve this issue?
>
> <http://cygwin.com/cgi-bin2/package-grep.cgi?grep=Python.h>
>
> So, do you have Python installed?

Yes. I have python 2.5 installed using Setup.exe. In debian I had the
same issue with python enabled GDB. But I could solve it by installing
the python2.5-dev development packages. I had a look at the files
included in cygwin package (you mentioned) and the files in
python2.5-dev deb package:
http://packages.debian.org/lenny/i386/python2.5-dev/filelist

The observation is that python static library (in case of linux-
libpython2.5.so in /usr/lib/) is missing in cygwin and that is exactly
what gcc is complaining when building gdb (please refer to the config
log in my previous post). I dont know whether this is handled
differently in cygwin. Please give your suggestions.

-Sreejith

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list