Bug to setup Cygwin on Windows Server 2008 64bits

Kyeto kyeto@free.fr
Thu May 14 10:10:00 GMT 2009


I still block on the prompt bash.

I don't arrive to have a valid and read shell.
When i run ssh-host-config, i have error with bash.exe and Windows 2008 send
me a repport.

I have try with the "-l" but not success.
With the .bat it's the same

Thanks for your help


Andy Koppe wrote:
> 
> 2009/5/7 Georg Nikodym:
>>
>> On 7-May-09, at 10:56 AM, Kyeto wrote:
>>
>>> I have disabled DEP and now Cygwin run.
>>> But i have just the pompt with :
>>>    bash-3.2$ : _
>>>
>>> None commands are available
>>> When i do a "ls" => command not found.
>>> It's the same for a lot (touch, chmod ...)
>>>
>>> But, pwd, cd work
>>
>> Normally, people start cygwin using cygwin.bat (or an icon on their
>> desktop
>> that does the same).  This sets up some useful stuff.
>>
>> From the picture in your previous post, you just started a shell
>> (bash.exe)
>> inside a command window.  In other words, there no guarantee that any
>> useful
>> environment was set up.
> 
> Yep. To get the usual environment, bash needs to be invoked with
> option --login (or -l), which makes it a "login shell" and ensures
> that /etc/profile is executed.
> 
> Andy
> 
> --
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
> Problem reports:       http://cygwin.com/problems.html
> Documentation:         http://cygwin.com/docs.html
> FAQ:                   http://cygwin.com/faq/
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Bug-to-setup-Cygwin-on-Windows-Server-2008-64bits-tp23422628p23537721.html
Sent from the Cygwin list mailing list archive at Nabble.com.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list