Cygwin 1.7, Win 2008 and rebase

Lenik lenik@bodz.net
Thu May 14 00:14:00 GMT 2009


On 2009-5-14 5:11, Darren Syzling wrote:
> I've just installed cygwin 1.7 for use under Winn 2008 - the latest
> version of 1.7 setup released today. I've read the threads on rebase
> issues with Vista but so far none of the suggestions help with my
> git-svn issue. After installation I ran through:
> ash
> /usr/bin/rebaseall
> /usr/bin/peflagsall
>
> Rebooted a number of times but whenever I use run git svn:
> git svn --version
>
> I receive:
>
> 183 [main] perl 3588 C:\cygwin\bin\perl.exe: *** fatal error - unable to
> remap C:\cygwin\bin\cygsvn_subr-1-0.dll to same address as
> parent(0x6FB30000) != 0x6FE60000
> 46 [main] perl 3488 fork: child 3588 - died waiting for dll loading,
> errno11
>
> Any suggestions or have I may be missed some steps with the new version
> of rebase?
>
> Regards
> Darren
>
I have uninstalled Vista and backed to XP, the following script is used 
to launch cpan for the same error in Vista. I don't know whether it can 
solve git svn's problem. And it's written several months ago for cygwin 
1.7.0-35(or earlier), maybe not work for the most latest version.

1) bash session:
     find /etc/setup -name '*.lst.gz' | xargs gzip -d -c | grep -E 
"\.(dll|so)\$" | sed -e '/cygwin1.dll$/d' -e 's/^/\//' >/tmp/libs
     grep    lib/perl5 /tmp/libs >/tmp/libs-perl5
     grep -v lib/perl5 /tmp/libs >/tmp/libs-nonperl
     find /usr/lib/perl5 -iname *.dll >>/tmp/libs-perl5
     sort -u /tmp/libs-perl5 >/tmp/libs-p

2) quit bash and start a new cmd.exe session:
     rebase -vdb 0x70000000 -o 0x100000 -T /tmp/libs-nonperl
     rebase -vdb 0x10000000 -o 0x20000 -T /tmp/libs-p

See also,
http://lenik.99jsj.com/programming/cygwinperl-fatal-error-under-vista

Good luck,

Lenik


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list